Data Exploration




What is IMP?
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analytics

What gets the most
attention in the
~d

classroom? -

Which topics do |
we spend the most

\

From Building Better Models with JIMP Pro, Grayson,
Gardner and Stephens, 2015.

- What is the most

‘« time consuming in
| practice?

May loop back
at any step
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The “good” stuff

I.:vl
[
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May loop back
at any step
Data Preparation:

Assess data quality

Clean and transform data
Examine and understand data
Define features

Create training, validation and
test sets

Communication:

e Visualize results
- e |nteract with models
o Explore “what if” scenarios
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Features In
JIMP

e Columns Viewer
Distribution
Graph builder
Data filter

Missing Data Pattern and Tree
Map

Fit Y by X
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Recode

Interactive Binning Add-In
Dynamic Transformations
Bubble plots

ge)ill=]

Applications — one click
HTML5




Exploratory Analysis

Working with Data
a. JMDP Basics
b. Examining and Understanding Your Data
*  One column
¢ Two columns
¢ Many columns (Graph Builder)
Common Problems
o Missing data
Messy data
e Data in wrong form (from excel, data types, need to derive or transform)
» Working with dates
+ Joining tables? Getting your data together for modeling!
. Dimension reduction methods
¢ Binning Data

¢ (lustering Data

» Principle Components Analysis and Variable Clustering
. Exercises and Further Reading
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Introduction

In this section we introduce some tools for working with
and exploring data:

e Distribution — always a good starting point!

e Tabulate — for summarizing data

e Graph Builder —drag and drop, GUI graphing interface
e Mapping — create geographic maps with Graph Builder
e Data Filter — dynamically stratify data

 Tree Map — an alternative to Mosaic Plots

e Partition — use for exploring potentially important
variables. Nice when there are many variables, nominal
variables, missing values, and messy data.
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Jmp

SCalrd v Cominep

Navigating JMP’ in Windows

jmp.com/flearn

rev 07,2012

This page gives information on the Windows JMP interface. For information on creating a new data table,

opening data tables, and finding help within JMP see the page Opening JMP and Getting Started.

The Home Window

When you first open IMP, you'll see the Tip of
the Day window.
You'll also see the new JMP Home Window (to
the right), which provides access to:
Menus and toolbars (top).
Recently used files and help (on the left).
All open data tables and windows (on the
right). Hover aver an item in the list for a
preview.
The IMP Starter, Home Window and other

features can be accessed via the View menu.
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Navigation

Data tables display thumbnails of open reports (bottom left).

b RN

Hover over a thumbnail for a preview.

Distribndines
Waight

Each data table and report provides icons (bottom, right corner)
to facilitate navigation between windows:

> Return to the Home Window (or, click CNTL — 1).

[ % Go to the data table.

¥ Select to arrange with other windows.

Tips:

Each window has a JMP menu and toolbar.

To view a hidden menu click Alt, or hover on the report

window where the menu would normally appear.

To have menus and toolbars always display, go to File >

Preferences > Windows Specific and change Auto-hide
menus and toolbars from Based on window size to

Never.

The JMP Home Window and Tip of the Day appear by e o s

Te A kW prke e | eplicilky cpan il v

default when IMP is opened. To change the default R —

§ i Ak

windows, use File > Preferences > General. elimg

i e
T kel fannowaliona

Note: For more details, see the book Using JMP (under Help > Books).
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Mews and Events Resources for Users

Basic instructions on how to get the most out of JMP, including quick overviews, step-by-step

tutonals. and videos

> Using JMP > Multivariate Methods
» Graphical Displays and Summaries > Data Mining
> Probabilities and Distributions > Quality and Process
> Reliability and Survivability

> Designed Experiments

» Download all the One-Page Guides combined into one PDF

http://www.jmp.com/en_us/learning-library.html




1% JIMP Home Window - JMP Pro

File Tables DOE Analyze Graph Toeols Add-Ins  View Window | Help

sm O Search the Help

Help Index

Books Book Descriptions

[

Mew Features Discovering JMP
IMP User Community Using JMP
ek Basic Analysis

S Eszential Graphing

Tip of the Day Profilers
Sl = Design of Experiments Guide
SEL L I Fitting Linear Models
Specialized Models
@ About IMP Multivariate Methods
Quality and Process Methods
Reliability and Survival Methods

Consumer Research

Seripting Guide
J5L Syntax Reference

Menu Card
Quick Reference

IJMP Documentation Library
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Sample Data

| Help
Help Contents

C,  Search the Help

Help Index
Books

Mew Features

JMP User Community
utorials

Sample Data

Tip of the Day

Statistics Index

Scripting Index

& About IMP

B2 Sample Data Index - IMP Pro

File Edit Tables Rows Cols DOE  Analyze

4 About this Sample Data Index

Graph Tools Add-Ins  View Window Help
= L Rk ;1?22 @ | N PA+ LSOO

This is an Index to some of the sample data tables provided with
IMP. Choose a subject heading below and open it to see a list of

data tables you can use to explore that topic, Click the blue

underlined file narme to open a data table. Then, within each data
table, study the table notes and column notes for more information,

|Gper1 the Sample Data Directn:lr;,r|

|See an Alphabetical List of all Sample Data Fi|E5|

| Open the Sample Scripts Directar}rl

|Clper1 the 5ample Applications Direct-:nrj,r|

Sample files categorized by type of analysis
Analysis of Variance

Bivariate Analysis
Categorical Models
Control Charts
Graph Builder

Design of Experiments

Fishbone/Ishikawa Charts (Dia
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Sample files categorized by type of data

Business and Demographic
Food and Nutrition

Industrial Experiments
Medical Studies

Positional Data

Psychology and Social Science

Sciences




Statistics Index

| Help &= Statistics Index - IMP Pro

Help Contents quantile: normal quantile plot, single population  # R?

uantiles
T, Search the Help g e Definition:

Help Index A measure of degree of fit, ranging from 0 (no fit) to 1 (exact fit). R*is reported in

R’ adjusted most regression fit reports,

Books R’ entropy
R® generalized

[Topic Help|| Launch ||Rur‘| Examplel

Mew Features Fl:, FNAXImum Names Default T
random effects Open (

Random Forest® "SSAMPLE DATA/Big Clas=.jmp"
range ) =< B

range chart Bun Script{ "Fit Model™ )
Sample Data range odds ratios
range risk ratic
rare events chart

IJMP User Community

Tutorials

Tip of the Day

. recurrence analysis
Statistics Index recursive Partitioning
regression tree

regression: logistic

regression: multiple regression

& About IMP

Courtesy of Mia Stephens: DSI 2014 Presentation




Figure3.l:  ExampleData Table in JMP

OOl Anabyre  Leap A . it [ o

File Name EECW P BT H :
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Hobes Selected Data o Type ($M) {§M) #Employ mp  Asseis sales
Tables Panel &8 1 Computer 355 1 7523 412070 6152 .63
@& 2 Phammaceuti big 54535 859 40929 210071 48516 1577
REd TriﬂnglE —&- Columns (8/1) @& 3 Compuler ST M531 T 157 3200 18658 2233 7 7 10

i Type Pharmaceuti big GT4T0 11022 DO 58815 16,34

= oo o - 5 Compuer _——— Data Grid

| ;\ﬁh*. lé—l.‘.'- & Pharmaceuti big 0472 0 470 54100 138077 24970 7.93

| g Profis (SM) T S e e (Rows and

4 # Employ 8 Computer  smal 09,3 41.4 5000 8280.00 468 584 Columns)

4 profitemp4 o Comoaiae  Tnna —— o s s = o 23 08
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- 0 Compute 847 890 .
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13 Compuler  big 118090 829 95000 872632 100750 8497
14 Computer  smal 8736 79.5 8200 9695.12 8080  9.10

300 130204 79190 10 99

Columns Panel —

= Rows
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Selaclad 1 UL DG Lt K

RGWS P-EEI'IE' —T¥icluded : 16 Phammaceuti smal ) 2 227 4 18 BE530. 1 T84 0 %3 45
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Data sets in JMP, called data fables, consist of a data grid with data (on the right) and
panels (on the letft) that define the data and the variables.

An example data table, Companies.jmp, is shown in Figure 3.1 (figure borrowed from
the one page guide, JMP Data Tables). This data table, and others we'll use in this book,
are available in the sample data directory (under Help > Sample Data).
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Historical data were gathered on 5960 bank customers to determine whether a customer
is a good or bad credit risk for a home equity loan. The data are stored in the file

Equity.jmpin the sample data directory (under Help > Sample Data).

The response (or Y) variable is BAD, which is coded as 0 (good risk) or 1 (bad risk). The
other variables are:

LOAN: The amountot the loan

MORTDUE: How much they need to pay on their mortgage
VALUE: Assessed valuation

REASON: Debt consolidation or home improvement (DebtCon or Homelmp)
JOB: Broad job category

YOJ: Years onthejob

DEROG: Number of derogatory reports

DELINQ: The number of delinquent trade lines

CLAGE: Age of oldest trade line

NINQ: Number of recent credit inquiries

CLNO: Number of trade lines

DEBTINC: Debt to income ratio

Building Better Models with JMP Pro, Grayson, Gardner and Stephens, 2015.




Variables are coded in JMP with a Continuous, Ordinal or Nominal modeling type. This

coding helps to make sure that JMP performs the correct analysis and produces
appropriate graphs.

e Continuous variables, like LOAN and MORTDUE, have numeric values (e.g.; 2,
5,3.35,159.667,...). These variables must be in decimal format, an can have no
special symbols or text.

Nominal variables, like BAD, REASON and JOB, can have either numeric or
character values, and represent unordered categories or labels (e.g.; the names of
states, colors of M&Ms, machine numbers,...).

Ordinal variables, which can also have either numeric or character values,

represent ordered categories (e.g.; small, medium and large; 1-9 severity rating
scales,...). This data set has no ordinal variables.

A first step in any analysis is to ensure that your variables have the correct modeling
type. To change the modeling type, click on the icon next to the variable in the data
table or in any analysis. JMP also allows for anumber of data types in addition to
modeling types. These can be changed using the Column Info window (right-click on a
column name and select Column Info). Note that there are a number of column
properties that can be specified from this window, including notes and formulas.

From Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




From

Exploring Data One Variable at a
Time

We start by looking at the variables one at a time. We use summary statistics and

graphical summaries to get familiar with our data and at the same time identify any
potential issues.

For continuous variables, we're interested in summary statistics, such as the mean (the
average), the standard deviation (the spread), minimum and maximum values, and the
number of missing observations. We're also interested in the shape of the distribution.
Is the distribution more or less symmetric? Is it skewed? Are there clusters of data or
severe outliers?

For categorical data (nominal or ordinal modeling types) we're interested in the number
of categories (or levels), the number of observations in each category, and the number of
missing observations.

Two key tools in JMP tfor exploring variables one at a time are Columns Viewer and
Distribution.

Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




The Columns Viewer provides numeric summaries of our data, as shown in Figure 3.2,
and is particularly usetul with large data sets (with many variables). (Go to Cols >
Columns Viewer. Select all of the variables from the Select Columns list, click Show
Quartiles, then click Show Summary.)

For the three nominal variables, BAD, REASON and JOB we see the number of
observations (N), the number of missing values (N Missing), and the number of
categories (N Categories).

For the continuous variables we also see N and N Missing, plus a number of summary

statistics. Of potential concern is the number of missing records, particularly for
DEROG and DEBTINC.

The Min and Max are the range of values for the variables. Many of the continous
variable have a minimum value of 0, and some of these have medians and quartiles that
are also 0. This may or may not be an issue, but it should be investigated. The mean is
the average value, while the median is the middle value (the 50% percentile). Big
differences between these two values would be an indication of potential skewness.

From Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




Figure 3.2: ColumnsViewer, Equit}' Data

Equity.jmp (5960 rows, 13 columns)

v Columns View Selector

Select Columns
Clear Select
* 13 Columns

[&BAD | Subset
ALOAN
AMORTDUE Show Summary
AVALUE
il REASON
il JOB Find Columns with Properties
AY0oJ
ADEROG
ADELINQ
ACLAGE
ANINQ
ACLNO
ADEBTINC

4 Show Quartiles

v » Summary Statistics

13Columns  Gjgar Select  Distribution

Lower Upper Interquartile
Columns N N Missing N Categories i Max Mean Std Dev Median Quartile Quartile Range
BAD 5860 0 2 . : . . . : -
LOAN 5960 0 : 83900 18607.969799 11207.480417 16300 11100 23300 12200
MORTDUE 5442 ‘ 399550  73760.8172 44457.609458 65019 46267.5 91493.75 45226.25
VALUE 5848 5 855909 101776.04874 57385.775334 89235.5 66062.5 119838.75 53776.25
REASCON 5708
JOB 5681 c ; : : ; c ;
YOJ 5445 ’ 41 8.9222681359 7.5739822489 7 3 13
DEROG 5252 . 10 0.2545696877 0.8460467771 0 0 0
DELINQ 5380 . 15 0.4494423792 1.1272659176 0 0 0
CLAGE 5652 : 1168.2335609 179.76627519 85.810091764 173.46666667 115.08969143 231.58738906 116.49769763
NINQ 5450 ; 17 1.1860550459 1.7286749712 1 0 2 2
CLNO 5738 ; 0 71 21.296096201 10.138933192 20 14.75 26 11.25
DEBTINC 4693 . 0.5244992154 203.31214869 33.779915349 B8.6017461863 34.818261819 29.13686439 39.005481694 9.8686173035
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The Distribution button (top, in Figure 3.2) launches the Distribution platform for
selected variables. This platform is also available from the Analyze menu.

In Figure 3.3 we see distributions for the first five variables. (In Analyze > Distribution,
select the variables and dlick Y, Columns, then click OK.) Categorical variables J]MP
produces bar charts and frequency distributions. For continuous variables JMP
produces histograms, box plots, and summary statistics.

By default, the view is vertical. This view allows us to see distributions of more
variables at one time. However, you can easily convert this to a horizontal view (click
on the top red triangle and select Stack). To produce horizontal histograms from
Distribution in the future, you can set a preference.

Back to the output in figure 3.3. Of the 5960 customers, nearly 20% were a bad credit
risk. The mean loan amount is $18607, but we see some extreme amounts. In fact, we
also see some extreme values for MORTDUE and VALUE — both of these variables
appear right-skewed.

All of the graphs in JMP are dynamically linked to the data table and to every other
graph. This allows us to explore potential relationships between variables. In Figure 3.3
we have clicked on the bar for bad risk customers (1). This highlights the bar, and we
can see how the bad risk customers are distributed across the other variables. For
example, we can see that more of the bad risk customers were consolidating debt than
taking out a loan for home improvement.

From Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




Figure 3.3: Distribution Output, first 5 Variables

- Distributions
v =~ BAD v - LOAN v ~MORTDUE v ~VALUE

= 90000 400000 850000
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DebtCon

v Frequencies v Quantiles ¥ Quantiles v Quantiles v Frequencies

Level Count Prob 100.0% maximum 89900 100.0% maximum 399550 100.0% maximum 855909 Level Count Prob
0 4771 0.80050 99.5% 72904.5 99.5% 239896.92 99.5% 298573.47 DebtCon 3928 0.68816
1 1189 0.19950 97.5% 50000 97.5% 192038.6 97.5% 244847.45 Homelmp 1780 0.31184
Total 5960 1.00000 90.0% 30500 90.0% 130348.4 90.0% 175166.3 Total 5708 1.00000
N Missing 0 750%  quartile 23300 750%  quartile 91493.75 75.0%  quartile 119838.75 N Missing 252
2 Levels 500%  median 16300 50.0%  median 65019 50.0%  median  89235.5 2 Levels

25.0%  quartile 11100 250%  quartile  46267.5 250%  quartile  66062.5

10.0% 7600 10.0% 26941.7 10.0% 48800

2.5% 5000 25% 12726.95 2.5% 32866.7

0.5% 2500 0.5% 5830.62 0.5% 20527.565

0.0%  minimum 1100 00%  minimum 2063 0.0%  minimum 8000

v ~ Summary Statistics v ~ Summary Statistics v ~ Summary Statistics

Mean 18607.97 Mean 73760.817 Mean 101776.05
Std Dev 11207.48 Std Dev 44457 609 Std Dev 57385.775
Std Err Mean 145.17267 Std Err Mean 602.65233 Std Err Mean 750.41338
Upper 95% Mean 18892.561 Upper 95% Mean 74942.257 Upper 95% Mean 103247.14
Lower 95% Mean 18323.379 Lower 95% Mean 72579.378 Lower 95% Mean 100304.96
N 5960 N 5442 N 5848
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From

In Figure 3.4, we see the next 5 variables in the data set. Recall from Figure 3.2
that some of the continuous variables, like DEROG and DELINQ, had minimum
values of zero. For these variables, we can clearly see the distributions using the
histograms and quantiles. Most of the values are, in fact, zero.

In CLAGE we see another potential problem — 2 customers with loan ages near
1200 days (these can be seen in the box plot).

So far, we've identified four potential data quality issues:
Missing values from many variables
Skewed distributions, and a long right-tail in the distributions of some variables
Messy data — Continuous variables with many zeros

Outliers in CL Age

Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.
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Other

Office

Mar

v Frequencies

Count
767
948

2388
1276
109
193
5681

Level
Mgr
Office
Other
ProfExe
Sales
Self
Total
N Missing
6 Levels

279

Prob
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1.00000
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N
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Figure 3.4: Distribution Output, Next5 Variables
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Exploring Data Two Variables at a
Time

The dynamic linking allows us to start to get a feel for potential bivariate relationships
between our variables. Three additional platforms for exploring variables two at a time

are Tabulate, Graph Builder, and Fit Y by X.

Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




Tabulate is a platform for dynamically summarizing data an constructing tables of
descriptive statistics. The initial Tabulate window is shown in Figure 3.5.

Figure 3.5: Initial Tabulate Window

Drag variables from the columns list to the drop zone for columns and rows, then drag and
drop statistic of interest into the results zone to add new statistics. Click the Done button to

close the control panel and produce the final table.

v ~ Tabulate

Interactive table

To use the interactive table, drag and drop
columns or statistics into a drop zone.

Recall

¥13 Columns

i BAD
ALOAN
_AMORTDUE
AVALUE
il. REASON
il JOB
AYOJ
ADEROG
ADELINQ
ACLAGE
ANINQ
ACLNO
ADEBTINC

Freq |

Weight I

Page Column |

N

Drop zone for columns

Mean Drop zone for
Std Dev rows

Min

Max

Range

% of Total

N Missing

N Categories
Sum

Sum Wgt
Variance

Std Err

cVv

Median

Resulting Cells

Interquartile Range
Quantiles

Column %

Row %

All

Include missing for grouping columns
Order by count of grouping columns

Add Aggregate Statistics
Default Statistics
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In Figure 3.6 we see percentages for BAD for the two reasons and six job categories (drag
BAD to Drop Zone for Columns, REASON to Drop Zone for Rows, drag JOB just below
REASON, and then drag Row % to the results area). There are more loans for customers
consolidating debt than home improvement, and two job categories, Sales and Self, appear
to have higher risk of bad loans than the other categories. However, there are far fewer
customers in these two job categories.

Figure 3.6: Tabular summary of BAD versus REASON and JOB

v ~ Tabulate

REASON
DebtCon
Homelmp
JOB

Mgr
Office
Other
ProfExe
Sales
Self
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Figure 3.7: Means of Continuous Variables for Levels of BAD

v ~ Tabulate

BAD
0 1

LOAN 1902811 16922.12
MORTDUE 74829.25 B69460.45
YO 9.15 8.03
DEROG 0.13 0.71
DELING 0.25 1.23
CLAGE 187.00 150.19
NING 1.03 1.78
CLNO 21.32 21.21
DEBTINC 33.20 39.39

The means of the continuous variables for the two categories of BAD are shown in Figure
3.7. There appear to be some potential differences. For example, the loan amounts are
higher on average for low risk loans, while the debt to income ratio is higher for high risk
loans. These bivariate summaries highlight some potentially important variables.
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Figure 3.8: Initial Graph Builder Window

~ Graph Builder

Recall Dialog

Variables

*13 Columns
ik, BAD
ALOAN
AMORTDUE
AVALUE
il REASON
ik, JOB
AYod
ADEROG

ADELINQ
ACLAGE
ANINQ
ACLNO

¥ Points
Jitter [/
Summary Statistic None

Error Bars

Variables >

A graphical version of Tabulate is the Graph Builder. This is the first option under the
Graph menu, and is a flexible graphing and exploratory platform. The initial window is
shown in Figure 3.8. Like Tabulate, Graph Builder uses drop zones for specifying the
variables to display. The primary zones are Y, and X, but there are other zones along the top
and right that allow you to add additional information to the graph. The icons across the

top can be used to change the graph type displayed, and additional options for the selected
oraph element are provided on the bottom left, below the variable list.
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Figure 3.9: Box Plots for DEBTINC and LOAN versus BAD

» = Graph Builder
BAD vs. DEBTINC & LOAN

DEBTING
LOwMN

g €3

100 150 200 -20000 0 20000 40000 &0000 80000
DEETING LOAN

In Figure 3.9 we see box plots for DEBTINC and LOAN (drag BAD to Y, DEBTINC to X, and
LOAN after DEBTINC on the X zone, then click Done). We can see that more of the high risk
customers had a high debt to income ratio, and more of the high loan amounts were for low
risk customers.

Building Better Models with JMP Pro, Grayson, Gardner and Stephens, 2015.




Figure 3.10: Mosaic Plot of JOB versus BAD

» ~ Graph Builder

BAD vs. JOB
1.00

BAD 0.50

When the X variable is categorical, different graph types are available. In Figure 3.10 we see
a plot of BAD versus JOB (drag BAD to Y, JOB to X, select the Mosaic graph element from
the icons at the top, then click Done).

This plot, called a mosaic plot, is an efficient way to graphically explore the relationship
between two categorical variables. The width of the bars across the bottom shows the
frequency of the job categories relative to one another. The bars are broken down, in this
case, by BAD = 0 (bottom) and BAD = 1 (top). From this, we can that there are very few
customers in sales or self-employed, the undefined Other category has the most customers,
and the lowest risk customers are office workers and professionals or executives. (Hint:
double-click on the x-axis to change the axis settings — here, we've changed the Label
Orientation to Angled to display all of the labels).

Building Better Models with JMP Pro, Grayson, Gardner and Stephens, 2015.




Figure 3.11: Fit Y by X Dialog Window

To formally analyze the relationship between two variables we use the Fit Y by X platform
from the Analyze menu. Like most platforms in JMP, Fit Y by X is contextual, producing
analyses based on the modeling types of the variables selected.

The Fit Y by X dialog window is shown in Figure 3.11. The icons on the bottom left indicate
what type of analysis JMP will provide based on the modeling type of the response and the
factor. In this example, we have selected a nominal response (BAD), so the two available
analyses are logistic regression and contingency. We have selected one continuous factor
and one nominal factor. JMP will produce both logistic regression (for the cgntinuous
factor) and contingency (for the nominal factor).

f Fit Y by X - Contextual
Distribution of Y for each X. Modeling types determine analysis.

Select Columns Cast Selected Columns into Roles

~13 Columns Y, Response | | ik BAD
il BAD

ALOAN Cancel
AMORTDUE
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ik JOB il JOB Remove
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ADELINQ r
ACLAGE Help
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OK

Mixed Platforms

1w
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ks .r’
all J
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Figure 3.12: Fit Y by X, BAD versus LOAN and JOB

» = Fit Group
» - Logistic Fit of BAD By LOAN
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» Covariance of Estimates
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i
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In Figure 3.12 we see partial results for both analyses. The mosaic plot is the same plot we
created using the Graph Builder, but summary information and statistical output are also
provided, along with many options under the red triangle. The logistic plot shows what
happens to the probability that a customer will be low risk (BAD = 0) as the loan amount
increases. Since the slope of the curve is positive, the probability increases (meaning that
the probability that the customer will be a bad risk (BAD = 1) decreases. We'll provide
background technical details on logistic regression in Chapter 5.

Building Better Models with JMP Pro, Grayson, Gardner and Stephens, 2015.




If our response were continuous, our two analysis options from Fit Y by X are bivariate.
Bivariate provides (correlation and regression) and oneway (two-sample t-Test and
ANOVA).

For an example, we use the Boston Housing.jmp data from the Sample Data directory. The
response variable of interest, mvalue, is the median home value (in $1000) for homes in the
Boston area in the 1970's. Two potential predictors are the number of rooms (rooms) and
a dummy variable indicating whether the town tracks the Charles River [chas).

On the left in Figure 3.13 we see partial results from the bivariate analysis, where mvalue is
the response and rooms is the factor. Here, we've fit a regression line (select Fit Line from
the red triangle]. On average, as the number of rooms increases the median value of homes
also increases. But, this plot provides additional information. For example, we see a
number of towns with median home values of 50 ($50,000). Itis likely that this was an
upper cutoff value of some sort.

On the right in Figure 3.13 we see partial results from the oneway analysis with mvalue as
the response and chas as the factor. We have selected Quantiles and t Test from the top
red triangle (and have selected Points Jittered from the red triangle > Display Options).
If the factor selected has more than two levels, then ANOVA would be available. The p-value
for the t-Test indicates that there is a significant difference in median home value for chas =
0 versus chas = 1 (the p-value for the two-tailed test is reported under Prob > [t]]. This
graph also provides additional information. For example, the number of points and the
width of the x-axis labels indicates that there are for more towns that do not track the
Charles River.

Building Better Models with JIMP Pro, Grayson, Gardner and Stephens, 2015.




Figure 3.13: Fit Y by X Output for the Boston Housing Data
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Exploring Data Three or More
Variables at a Time

From

Tabulate and Graph Builder, introduced in the last section, can also be used to explore more
than two variables at a time. For example, in Figure 3.14 (left) we see a tabular summary of
BAD by REASON and JOB within REASON, along with average loan amounts. On the right in
Figure 3.14 we have a graphical view of the same four variables, where the bar heights
represent the number of customers and the bar colors represent the average loan amount.

Figure 3.14: Tabulate and Graph Builder with Multiple Variables

v i+ Tabulate

REASON JOB

DebtCon  |Mgr
Office
Other
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20151.83
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16594.07

5308.33
27649.57

v ~ Graph Builder
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A popular view of potential relationships between continuous variables is a scatterplot
matrix (from Analyze » Multivariate Methods > Multivariate). A scatterplot matrix for
the first five continuous variables is shown in Figure 3.15. The points are colored by
BAD =0 (red) and BAD =1 (blue). Each box graphically shows the correlation, or the
linear association, between two variables. The first row contains scatterplots between
LOAN and each of the other variables. A density ellipse is drawn in each scatterplot to
provide an overall view of the relationship between each pair of variables.

Figure 3.15: Equity Scatterplot Matrix
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In this plot, we see that there is
a strong relationship between
MORTDUE and VALUE, and
weak relationships between the
other variables. We also see the
extreme values for MORTDUE
and VALUE across the other
variables.




Other Useful Features




Data Filter

* The data filter (Rows > Data Filter) allows you to
dynamically stratify data by values of one or more
filtering variables.

 From an open data table select the data filter. Then,
select a variable of interest, and click Add.

A= Data F||ter .I:Ilata Filter for SATByYear |
Add Filter Columns 4~ Data Filter
| dStudent/Faculty Ratio (1997) ‘ Add | \

ASalary (1997)

4% Taking (2004)
AX 4] Select [C] Show [ Include

Clear | 7] Auto clear

Y *'Region
APopulation Midwest (56)

4% Taking (1997) Mountain (56)
AACT Score (2004) New England (48)
AACT % Taking (2004) 5 Northeast (64)
AACT Score (1997) Pacific (40)
AACT % Taking (1997) ot o)
ihYear Southwest (40)
ASAT Verbal —— —————
ASAT Math +][1] [start Over
ik

Courtesy of Mia Stephens: DSI 2014 Presentation




Data Filter

e Select a value of the filtering variable (or a range of
values if the variable is continuous). The
corresponding values will be selected in the data
table and every

open graph.

-
m SATByYear - Graph Builder 2 - JMP

Data Filter for SATByYear /=21

4/~ Data Filter

‘ Clear | 7] Auto clear

56 matching rows

7] Select [C] Show [] Include

*'Region

Mountain (56)
New England (48)
Northeast (64)
Pacific (40)
Plains (32)

South (72)
Southwest (40)

‘E‘ |1| ‘Staﬁ Dver|

HAEH R E 23 @ N LA+ HSCO
4= Graph Builder

| Undo ||Start Over” Done |

Select Columns
T AX

AY

4 Population

4% Taking (1997)
AACT Score (2004)
ANCT 0 Taking (2004)
AACT Score (1997)
AACT % Taking (1997)
hYear

ASAT Verbal

ASAT Math

ik

110° W

Map shape not found: D C
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Data Filter

* Click Show in the Data Filter. All other observations
will be hidden in the data table.

* In Graph Builder, only the selected value(s) of the
filter variable(s) will display.

-
[ SATByYear - Graph Builder 2 - JMP

Data Filter for SATByYear /=1
HREH ¥and k2@ @ N pa+@OsSC O

4~ Data Filter 4~=Graph Builder

| Clear ‘ 7] Auto clear | Undo | |start Over|| Done |
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South (72)

Southwest (40)
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|E‘ |1| |Start O\.rer‘ 10° W

Map shape not found: D.C..
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Data Filter

e Click Exclude in the Data Filter. All other
observations will be excluded in the data table.

e Graph Builder will automatically update — only
selected values will be included in the graph and
calculations.

Data Filter for SATByYear /=1 E
SRdd ¥2ia 2 #+& N pQA+ES0 O
4~ Data Filter 4/=Graph Builder

| Clear ‘ 7| Auto clear | Undo HStar‘t Over” Done |
Em— Select Columns

56 matching rows =t X
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New England (48) . Year 42.5° N
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-
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Where(Region = Midwest)
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Tree Maps

* Tree maps (Graph > Tree Map) are an alternative to

Mosaic Plots for displaying nominal data.

e Select Categories, a Size variable, and an Ordering

variable (Example: ParetoDefect.jmp).

[+ ParetoDefect - Tree Map of Defective Items by Description 2 - JMP

4~ Tree Map of Description Sized by Defective Items

-|', Tree Map - JMP = | oD

Categories tiled proportional to size
Select Columns CasrSetectea-Colammis o Roltep

~|dDefective Items |?

k.Description — P
kProduct |Categones|§ h p

| 4 Defective ltems

0-Ring

Poor Seal
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Tree Maps

* Add a second Category variable, and add a Coloring
variable:

[+ ParetoDefect - Tree Map of Defective Items 3 - JMP

4~ Tree Map of Description, Product Sized

B Tre Mep - VP - by Defective Items Colored by Product
Categories tiled proportional to size :‘E't E B D

Select Columns EasrSelecrea-Colammmis o Noies

~ dDefective Items | Sizes | 4Defective Items
h.Description
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Product |Categorles| L ==
LG ik Product F|n|5h

|M| Defective Items — T A

E

| Coloring | Product
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A E C
Poor Seal Scratch
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Introduction to Partition

e Partition (Analyze > Modeling > Partition) is a data
mining tool, used for data exploration and for
building predictive models.

 We will introduce the tool here, and will revisit the
topics again later.

. Example: Autc Raw Data.jmp in the Sample Data

Directory. i rorion- e

Recursive partitioning
Select Columns Cast Selected Columns into Roles Action
~ 4Sample # " |V, Response| & Claim(Y/N) | oK |
.Claim(Y/N)
AClaim USD
hAge
hAgeClass
Gender

| X, Factor ||I.Age(3|ass
ik Gender
Car Power
ik Rating Class
. Region
ik City(Y/N)

Missing value categories | Weight |

Validation Portion Freq

By
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Introduction to Partition

e JMP displays a graph with a line drawn at the overall
reS po n Se rate . [ |sf! Auto Raw Data - Partition of Claim(Y/N) - IMP

|
4= Partition for Claim(Y/N)

2
E
£
O

" All Rows

| Split || Prune HCczulcur Pcuints‘ Number
RSquare N of Splits
0.000 20000 0

~All Rows
[
Count GA2
20000 14677
Level Rate Prob
N 0.8800 0.8800
Y 0.1200 0.1200

b Candidates
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Introduction to Partition

e Click the Split button. The [
original observations will be
split into two nodes, or
leaves.

Interpretation:

§|F’rune|| Go ||Cculcur Points Number

° In the Ieft Ieaf ’ RSquare N of Splits  AICc
) Training 0.050 13997 1 345839

Validation 0.047 6003

~All Rows

corresponding to AgeClass =
Young, the probability that To e o,

Level Rate Prob

thereis a claim is 0.3604.

Y 0.1188 0.1188

o I n t h e r i g h t | e a f’ ‘Agemasswg) 'AgeCIass(EId:r)

Count Gn2 Count Gn2

COrrespOndlng to Ag@ClaSS — 1157 1512.5612 12840  8179.881

Level Rate Prob || Level Rate Prob
N 06396 0.6398||N 0.9030 0.9030

Elder’ the pro ba bility that Y :_)35:)4 03602 Y !.)DE!?D 0.0970
. . . Candidates Candidates
there is a claim is 0.097.
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Introduction to Partition

e Click the Split button again, and then a third time. The

original observations will be split into two nodes, or
leaves.

Jsf Auto Raw Data - Partition of Clai
4~ Partition for Claim(Y/N)
~All Rows

Count G*2 LogWorth
20000 14677 158.82607
Level Rate Prob
N 0.8800 0.8800
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I I

Count GA2 LogWorth Count GA2 LogWorth
1684 2196.957 29.285233 18316 11755661 137.15102

Level Rate Prob Level Rate Prob

N 0.6419 0.6421 N 0.9019 0.9019
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~ICity(Y/N)(Y) ~/City(Y/N)(N) ~ICity(Y/N)(Y) ~City(Y/N)(N)
I I I |

Count Gn2 Count G2 Count G2 Count G2

934 1292 5325 750 77489174 10103 8381.9675 8213 2748982
Level Rate Prob || Level Rate Prob| |Level Rate Prob | Level Rate Prob
N 0.5246 0.5250|N 0.7880 0.7881| [N 0.8545 0.8545|N 0.9602 0.9602
Y 0.4754 0.4750|Y 02120 02119| |Y 0.1455 0.1455|Y 0.0398 0.0398

Candidates Candidates Candidates Candidates
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Saving Results




jmp.comflearn rev 07/2012

Saving JMP’ Results

This page gives information on saving JMP output and results.

The Selection Tool = Copy and Paste to Another Program

From any JMP output window, click on the selection tool in

the toolbar or use the keyboard shortcut (5).

Click on the content you'd like to copy — selected content is

highlighted. Click near the edge of the report to select all 'jh'p:' e pe o s

- Diskributions

content. To extend a selection, hold the shift key.

Type

Click Edit > Copy (or Control-C). B .

Open the program where you'd like to paste the content, and

select Paste. To paste as an object, select Paste > Paste

Special and from the list select Picture (Enhanced Metafile). —

If using a Mac, select Paste, or use Paste Special > PDF for

high-quality graphics.

http://www.jmp.com/academic/learning_library.shtml

Courtesy of Mia Stephens: DSI 2014 Presentation




Save Your Work Using Scripts

You can save the steps taken to produce a report as a ISL script (JSL is “JMP Scripting Language”). This enables
you to recreate the report at any time.

1. From any JMP output window, click the top red triangle and select Script > Save Script to Data Table.
2. The saved script will appear in the tables panel of the data table.

3. To run the script, click on the red triangle and select Run Script. To edit (change the name), select Edit.
4, Select File » Save to save the saved script and any other changes to the data table.

|55 Car Phyzical Deta - Distribution of Type. Weight - IMP = Car Physical Data - JME
File Edit Tables Rows Cols DOE  Anabze Greaph 545 SwSigmaTools Took Teach A

ex 2 43 B |22 @ e A+ OISO o

File Edit Tables Rows Cols DOE  Analyze Graph 5A5 5SmSgmaTools Tools Teach

R = - HREd %a 8 B el D, F M 5 iE B
£ = Distributions
Uniform Scaling = Car Phy=ical Data

# Skack | . - | Model Country
—| 4 Fraquencies

Run Seripk
i Acura Integra Japan

Save for Adobe Fash platform [SWF)... -y

Senpl sk Analysis Ll Acura Legend VE Japan
Felaunch Anahysis Delete . 3 Audi 100 Other
Autoratic Recalc Copy Audi 80 Cther
Cepy Seript B | Audi 90 Cither
Sk 5t yte Dista Table i i | BMWY 3250 Oither
M : Debug Scrpt BMW 535i Other

Sewe Seript to Seript Window [ Buick Century LUSA

4= Weight Sewe Script ta Report = Columns (8/0) Buick Electra V6 UsA

Szwve Script far All Objects ik Model&= 10 | Buick Le Sabre VE (NETN

F——— & 1— |swsSciswiuia ik Country 11 | Buick Riviera V6 Usa

Diata Table Windou St i Type ¥ 12 Buick Skylark Usa

St 4 Weight - N - .
13 | Cadillac Brougham VB Usa
L 4 Tuming Circle gham Y =

M) e — Lo : 14| Gadillac De Ville V8 USA
__I__E L EC 00 macian, b ' o a1 4 Displacement | P ES— F— it P

Sparty

Local Ciata Filter

Notes: Select Edit > Save Selection As (or File > Export on the Mac) to save the selection in a variety of graphical
formats, including JPG, EPS, SVG and GIF. To change default graphic formats, use File > Preferences > Windows
Specific (or JMP > Preferences > Mac 0S Settings on the Mac).
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Publication-Quality Graphics — Windows

Saving Graphic Images

From any JIMP output window, click on the selection tool in the toolbar or use the keyboard shortcut (S).
Click on the content you’d like to copy — selected content is highlighted. Click near the edge of the report to
select all content. To extend a selection, hold the shift key.

Select Edit > Save Selection As.

Under Save as Type (at the bottom of the window), select the desired graphic format. JPEG File (".jpg)
PNG File (*.png)

For printed media (presentations, journals, etc.) a vector image, such as EMF (enhanced

metafile) is recommended. This format preserves transparency, can be edited in image- E;g FF_ille_':'E‘g_]
ile (*.eps)

editing software, and can be scaled or resized without losing clarity. PDF File (*.pdf)

EMF File (*.emf)

If a bitmap graphic format (PNG, JPEG, GIF or TIFF) is selected, change the Image DPI GIF Files (*.gif)
Setting to 300 for a high-resolution graphic. TIFF File (".iff,".tif)

Enter a file name, specify the folder to save the file to, and click Save.

. . . . JMP Journal (*,jm)
Note: To save all of the output in the active window, use File > Save As. JMP Report (*.jrp)
Text File (*.txt)
Interactive HTML with Data (*.htm:*.html)
HTML File (*.htrm:*.html)
RTF File (".rtf)
Microsoft Word 2000+ (*.doc)

In addition to the graphics formats, several report formats are available.
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Saving Graphic Images

In IMP, go to File > New > Script. P . =
Type the following code in this window: pref(Save Image DPI{600)); pref (Save Image DOT ¢_]}_

Right-click, and select Run Script.

This will change the default for all saved graphics to 600 (or whatever

number you plug into the parentheses) until you change the default.

Tips:

o Edit the graph in JMP prior to saving in a graphics format. For example, change the size of the graph

frame, change marker sizes and/or colors, and edit axes, legends and titles prior to saving.
When copying and pasting into Microsoft Office products, use Paste Special > Picture Enhanced

Metafile to paste output as vector images.
The EPS vector format does not preserve graph transparency (EMF does).

IMP report elements that use Open GL (surfaces, scatterplot 3-D, etc.) cannot be output as vector

images.
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Summary

In this section we introduced some tools for working with and
exploring data:

e Tabulate — for summarizing data, a drag and drop pivot table

e Graph Builder — dynamically graph data, explore many
variables at a time.

 Mapping — geographic maps from Graph Builder, also available
from Bubble Plot

e Data Filter — dynamically stratify data
 Tree Map — an alternative to Mosaic Plots

e Partition — Use to explore potentially important variables when
there are many variables, nominal variables, missing values,
and messy data
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